之前一直玩编译安装的办法,现在回过头去看实在没有必要。 就好比 iPhone 的越狱,以前也是乐此不彼。

言归正传,安装一个统计插件, 需要 php 5.4 以上支持,没有办法,需要更新 PHP 5.3.3。

原文在这里:

https://www.mojowill.com/geek/howto-install-php-5-4-5-5-or-5-6-on-centos-6-and-centos-7/

我做的一个简约的步骤:

rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm
yum-config-manager –enable remi,remi-php56
yum install php php-gd php-mysql php-mcrypt php-xml
就这么简单,之后重启一下 Apache (service httpd restart)。在浏览器上写一个简单的 test.php
<?php
  phpinfo ();
就可以查看 PHP 是否最新的版本。